Home    Forums    Feature Requests    Beta Issues    SysAid Resources    Documentation    Support    Do It Yourself
Hello Guest,  Login   
        
DOWNLOAD FREE EDITION
    
     Recent Topics    Hottest Topics    Online Members    Member Listing    Advanced Search
How to - Add HTML tags to your SysAid notifications  XML
Forum Index » SysAid Integration
 
Author Message
Haim
SysAid Wiz

Joined: 15/04/2008
Messages: 2449
Offline

HTML in SysAid Notifications
Here's something you should know: The E-mail notification sent by your SysAid doesn't have to be written in plain text!
You may in fact, use any HTML tag to create a notification which is pleasant, easy to read, and may even include images such as your company logo, or any other image that can be useful for you.
Basically, you can enable HTML emails on the entire system.
To set this up:

1. Please go to Preferences > Integration > Email tab
2. Fill in the Encoding filed with the relevant information- this varies according to the encoding you use in SysAid. If the encoding you use is Unicode, please replace it with: UTF-8.
3. Fill in the Content Type field with the line: text/html; charset=utf-8 *ADMIN EDIT BY TECHGUY - text/html must all be lowercase *
4. After setting the HTML email type, you can use any email tags in your email notifications: <a>, <img>, <b> etc.

This message was edited 1 time. Last update was at 27/02/2009 14:36:20


Pushing IT forward
Obelix
SysAid Wiz


SysAider from release 3.1 Indonesia Pathfinder
Joined: 12/06/2008
Messages: 903
Offline

Don't forget to put HTML linebreak tags where necessary or your notification will look like a very neat spam...
Obelix
SysAid Wiz


SysAider from release 3.1 Indonesia Pathfinder
Joined: 12/06/2008
Messages: 903
Offline

Following up on this...
There's an annoying side effect - on the messages, all the bloody html tags appear !

What say you Haim ?
*hobit look*

This message was edited 1 time. Last update was at 13/06/2008 04:19:28

Haim
SysAid Wiz

Joined: 15/04/2008
Messages: 2449
Offline

Oblix, which version of SysAid are you running? i believe this has been sorted in 5.1.08 ot 5.1.09

You can update your SysAid at: www.ilient.com/patches.html


Pushing IT forward
Obelix
SysAid Wiz


SysAider from release 3.1 Indonesia Pathfinder
Joined: 12/06/2008
Messages: 903
Offline

5.108.

Hmmm.... never know SysAid got patches.

The link doesn't work...
There's however http://ilient/patch, unfortunately it's forbidden for regular user.

How do I get the patches, bro ?

This message was edited 2 times. Last update was at 14/06/2008 01:19:37

simplydobermans
SysAider

SysAider from release 5 United States
Joined: 16/06/2008
Messages: 43
Offline

go to http://www.ilient.com/patches.htm
this will give a list of all available updates
You may need to do several updates, depending on the age of your current SysAid running
Obelix
SysAid Wiz


SysAider from release 3.1 Indonesia Pathfinder
Joined: 12/06/2008
Messages: 903
Offline

Ay yay yay.... the bloody extra "l" !
Thanks Haim... Thanks doberman...

Wait...
Is there notification to users when new updates are released ?
Haim
SysAid Wiz

Joined: 15/04/2008
Messages: 2449
Offline

Obelix wrote:Ay yay yay.... the bloody extra "l" !
Thanks Haim... Thanks doberman...

Wait...
Is there notification to users when new updates are released ?


Of course, we always send emails to our users.
If you don't receive them, try checking your spam filter.


Pushing IT forward
René Rijk
Elite SysAider


SysAider from release 5.1 Netherlands
Joined: 15/06/2008
Messages: 234
Location: Netherlands
Offline

Hi everyone,

I managed to set the E-mail to HTML but I noticed that not all the HTML tags will be recognized.
Perhaps I do something wrong?
When I use a tag like you see underneath, nothing changes in the e-mail notifications.

{FONT FACE="Times New Roman" SIZE="+3" COLOR="#FF0000"}Some text{/FONT}

In this example I use {} instead of the normally used <> otherwise you can not see the code.

How can I make this work? Or are those HTML tags not recognized by sysaid..

Best regards,
René

Take a look at my 3D creations and here is a little animation I made
[WWW]
Haim
SysAid Wiz

Joined: 15/04/2008
Messages: 2449
Offline

Hello Rene,
I know that the <font> tag work on SysAid, so there shouldn't be any errors.
How the text present in the notification? does all the settings are ignored or just some of them?


Pushing IT forward
René Rijk
Elite SysAider


SysAider from release 5.1 Netherlands
Joined: 15/06/2008
Messages: 234
Location: Netherlands
Offline

Hi Haim,

The whole text is ignored by the tag. It does not matter if I change the font to Calibri or Times new roman, it always show in the same (standard)font.
And as I wrote, even the color tag is ignored.
The brake tag and the line tag works ok.
Mmmm strange..

I'll try again..

Kind Regards,
René

Take a look at my 3D creations and here is a little animation I made
[WWW]
Obelix
SysAid Wiz


SysAider from release 3.1 Indonesia Pathfinder
Joined: 12/06/2008
Messages: 903
Offline

Settings of how mail displayed reside both on the client and the server.

Are yours exchange-outlook ?
René Rijk
Elite SysAider


SysAider from release 5.1 Netherlands
Joined: 15/06/2008
Messages: 234
Location: Netherlands
Offline

We working with EXchange indeed.
I've solved the problem. At first I wrote the code/tags as shown underneath,

<font face="arial" size="3">some text</font>

But that did not work,

After some trial and error I noticed that I must wrote it like this,

<font face=arial size=3>some text</font> So that is without the " " <- I don't know the English name for those.

Anyway it works now....
Thanks for the help.

Best regards,
René

Take a look at my 3D creations and here is a little animation I made
[WWW]
seanick
SysAider

SysAider from release 4.5 United States Pathfinder
Joined: 11/06/2008
Messages: 11
Offline

René Rijk wrote:We working with EXchange indeed.
I've solved the problem. At first I wrote the code/tags as shown underneath,

<font face="arial" size="3">some text</font>

But that did not work,

After some trial and error I noticed that I must wrote it like this,

<font face=arial size=3>some text</font> So that is without the " " <- I don't know the English name for those.

Anyway it works now....
Thanks for the help.

Best regards,
René


I've noticed that the system doesn't really work that nicely with HTML emails. And, if you have to remove the quotes (or even escape them) that makes for some pretty nasty HTML code.

Any chance this will be fixed soon?
Maoz
SysAider

SysAider from release 5.5 Israel Pathfinder
Joined: 14/08/2008
Messages: 4
Offline

I tried adding HTML tags to the notifications and it works fine, to exclude tree-text fields. in such case (adding description filed to the body of the notification message), I'm 'loosing' all the line-breaks, so the entire description is presented as one long line.
is there a way to replace all line-breaks into <BR> in the notiifcation body?

thanks,
Maoz
Forum Index » SysAid Integration
Go to:   
Help Desk Software
Free Help Desk Software
Free Asset Management Software
SysAid Helpdesk Software
Web Based Help Desk Software
SysAid Help Desk Forum
General IT Discussion Forum
SysAid CSS Customer Service Software
Customer Support Software
   SysAid Technologies Ltd.
   Toll-Free phone center (U.S.): 1-800-686-7047
   Offices - U.S.617-231-0124
   Israel:+972-3-533-3675
   Email:helpdesk@sysaid.com
   Optimized by SEO Israel
   SysAid logos and other SysAid Technologies marks
   are trademarks or registered trademarks of
   SysAid Technologies Ltd.
   All Rights Reserved by SysAid Technologies Ltd.
   2002-2011
   Live Support Hours
   07:00 AM - 09:30 PM (UK)
   03:00 AM - 05:30 PM (EDT)

   We provide worldwide services, and we do our best
   to match the working times of customers from
   different time zones.

   SysAid Help Desk Software and Asset Management Software
Privacy Policy © Terms Of Use