SysAid RC Direct Connection Error

 
Author
Message
SysAider
8
 
Hello, I have been having some issues starting the SysAid RC Direct Connection Client.

I have the settings configured as the following;


The IP is the IP of the computer I am connecting from, the listing port is default to 4228, and my RC client is set to 'encrypt'.

The remote computer receives the request and accepts, SysAid shows a successful connection on my end;


Then the following error message appears;


Select 'Ok' and the following message appears;


Any insight into this would be much appreciated.

Thanks


SysAid Community Manager Product Team
4492
 
Hi Quackenbush,

If you right-click on the RC icon in your taskbar when the session is initiated, is "Encrypted" selected?

Thanks,
Danny
SysAider
8
 
Yes, I have the SysAid Remote Control Viewer set to 'Encrypt' and it is listing on Port 4228.

The remote computer receives the request, accepts the request, and on my end SysAid shows a request has been accepted but then I receive the errors that are attached in the image of the original post.

UPDATE;

It works with encryption turned off, going to test on other assests as I have not gotten this far before.

This message was edited 3 times. Last update was at Nov. 07, 2017 04:01 PM

SysAider
8
 
So with encryption turned off, I have no problem connecting to assets.

With encryption toggled 'on' in SysAid Remote Control Viewer the connection never starts although SysAid says it does.

With encryption toggled 'off' in SysAid Remote Control Viewer the connection starts.

When using 'Direct Connection' and selecting 'Encrypt Connection' it does not start the session.

Why cant I use encryption with this RC service?
SysAid Community Manager Product Team
4492
 
Interesting. Are you trying to connect to a Windows, or Mac device?
SysAider
8
 
Everything in our environment is a Windows based OS.

Direct Connection (Unencrypted) - Loads session

Direct Connection (Encrypted) - SysAid says session starts, nothing happens after that

SysAid Remote Control Gateway with SysAid Remote Control Viewer (Unecrypted) - Loads session

SysAid Remote Control Gatewat with SysAid Remote Control Viewer (Encrypted) - No session loads.


Also, I see that for Remote Connections the settings are stored locally on the computer, if we have over 100+ assets that we want to have RC access to will we need to go to each computer and change the settings locally?

Is there a registry key we could edit and then apply as a GPO?

Thanks

This message was edited 2 times. Last update was at Nov. 08, 2017 10:13 AM

SysAid Community Manager Product Team
4492
 
Thanks for the info, I'm checking this with our R&D team.

Regarding unattended RC - this is controlled in SysAid Agent settings, under Remote Control section - "End users must confirm remote control" needs to be unchecked.

Cheers,
Danny
SysAider
8
 
Danny Tashiev wrote:Thanks for the info, I'm checking this with our R&D team.

Regarding unattended RC - this is controlled in SysAid Agent settings, under Remote Control section - "End users must confirm remote control" needs to be unchecked.

Cheers,
Danny


Thank you for the quick responses, I look forward to hearing of a solution/resolution to the encryption issue.

As for my second question,

I did see that in the 'Remote Control Guide' after writing that post this morning. My question is this now;

I see that for Remote Connections the settings are stored locally on the computer, if we have over 100+ assets that we want to have RC access to will we need to go to each computer and change the settings locally?

Is there a registry key we could edit so we could then deploy as a GPO?

Thanks

This message was edited 1 time. Last update was at Nov. 08, 2017 10:14 AM

SysAid Community Manager Product Team
4492
 
You can simply select all the relevant assets in your Asset List and go to More Actions > Agent Settings. This might take a couple of minutes to take effect.
SysAider
8
 
Danny Tashiev wrote:You can simply select all the relevant assets in your Asset List and go to More Actions > Agent Settings. This might take a couple of minutes to take effect.


Thank you, I will test this today.
SysAider
8
 
While I seem to be making progress, I have hit another wall.

I can connect to machines without approval using SysAid Remote Control Gateway (Unencrypted)

When using a direct connection I have started receiving an error that I am unfamiliar with;

'The Plugin cannot be loaded, please check its name integrity'

I select OK and am presented with;

'Server closed connection - The server running as application'

Pictures attached
https://imgur.com/a/vdLui - Error 1
https://imgur.com/a/Y2pX8 - Error 2
SysAid Community Manager Product Team
4492
 
Hi Quackenbush,

Please open a ticket with our support team for further investigation, including all the information posted here in the ticket, and update here once a solution is found.

Thanks,
Danny
SysAider
8
 
Ticket has been opened

Case #;

1882813.
SysAider
1
 
I have the problem with my versione sysaid cloud. I don't connected with the agent also remote gateway or direct connection.
these remote control issues will be resolved with the new version?
Thank