Minimum Requirements for SysAid

SysAid Server (on-premise installations):

Item Minimum Required Recommended

Hardware

Processor(s) 2.0 GHz Quad-Core Xeon or equivalent
Memory 4 GB 8 GB
Free disk space 16 GB 32 GB

Software

Operating system (x64) Windows Server 2008 R2*
Linux/Unix**
Windows Server 2012
Database*** MS SQL Server 2014 Express****
MySQL 5.7 and above
Oracle 10.4 and above*****
MS SQL Server 2014

If you are planning to use SysAid Patch Management, make sure to also consider the Patch Management requirements detailed here.

* Windows 10, Windows 8, and Windows 7 SP1 can be used for test environments.
   - .NET Framework 3.5 SP1 or higher is required.

** When the SysAid server is installed on a Linux server, the SysAid RDS is required for agent deployments.

SysAid supports the following OS versions:
- Centos - 7
- Debian - 8 jessie, 7.7 wheezy, 9 stretch, buster 10
- Ubuntu - Xenial 16.4, Zesty 17.04, Trusty 14.4

*** For production environment it is recommended to use a separate machine for the database.

**** MS SQL Express requires an additional 1 GB of RAM, if running on the same machine, and can contain up to 10 GB of data (expected DB growth - dependant on number of assets and modules used, approx. 2-5 GBs per year).

***** Oracle is not supported by Linux installations.

 

Browser - Client Requirements:

Administrator Internet Explorer 11 and above, Microsoft Edge, Chrome, Firefox, Safari*
End-User Portal Internet Explorer 9** and above, Microsoft Edge, Chrome, Firefox, Safari*
Self-Service Portal Internet Explorer 11 and above, Microsoft Edge, Chrome, Firefox, Safari*

* Basic functionality has been tested.

** The End-User Portal has been tested on Internet Explorer 9 & 10 - we recommend using IE 11 and above.

 

SysAid Agent - Client Requirements:

Item Requirement

Hardware

Processor 1500MHZ
RAM 512MB
Free disk space 50MB*
RAM usage 20MB

Software

Operating System (x64, x86) Windows**: 10, 8, 7, Vista, Server 2016, 2012, 2008
Linux ***
Mac OS X 10.11 and above
Unix, IBM's AIX, FreeBSD, Solaris, HP-UX ****

* To enable Patch Management capabilities, an additional 1.5 GB is required.

** .NET Framework 3.5 or above is required.

*** For inventory feature only.

**** Through a third-party tool; please contact our support team for more information.


For more detailed System Requirements, see the full SysAid System Requirements help page.